|FSIRAND(8)||System Manager's Manual||FSIRAND(8)|
randomize inode generation numbers
fsirand command installs random
generation numbers on all the inodes for each filesystem specified on the
command line by special. This increases the security
of NFS-exported filesystems by making it difficult to “guess”
fsirand should only be used on an
unmounted filesystem that has been checked with
fsck(8) or a filesystem that is
fsirand may be used on the root
filesystem in single-user mode but the system should be rebooted via
“reboot -n” afterwards.
The options are as follows:
fsirand command appeared in SunOS 3.x.
This version of
fsirand first appeared in
Todd C. Miller
fsirand allocates enough memory to
hold all the inodes in a given cylinder group, it may use a large amount of
memory for large disks with few cylinder groups.
|January 25, 2019||OpenBSD-6.8|