|CDCE(4)||Device Drivers Manual||CDCE(4)|
cdce — USB
Communication Device Class Ethernet device
cdce* at uhub?
cdce driver provides support for USB
Host-to-Host (aka USB-to-USB) bridges based on the USB Communication Device
Class (CDC) and Ethernet subclass, including the following:
The USB bridge appears as a regular network interface on both sides, transporting Ethernet frames. USB 1.x bridges support speeds of up to 12Mbps, and USB 2.0 speeds of up to 480Mbps. Packets are received and transmitted over separate USB bulk transfer endpoints.
cdce driver does not support different
media types or options. For more information on configuring this device, see
Universal Serial Bus Class Definitions for Communication Devices, https://www.usb.org/document-library/class-definitions-communication-devices-12.
Data sheet Prolific PL-2501 Host-to-Host Bridge/Network Controller.
cdce device driver first appeared in
cdce driver was written by
based on the aue(4) driver
written by Bill Paul
and ported to OpenBSD by Daniel
Many USB devices notoriously fail to report their class and interfaces correctly. Undetected products might work flawlessly when their vendor and product IDs are added to the driver manually.
|May 12, 2020||OpenBSD-6.8|