|RAD(8)||System Manager's Manual||RAD(8)|
rad — router
rad is an IPv6 router advertisement
daemon. It periodically sends IPv6 router advertisement messages with prefix
and default router information. Clients like
slaacd(8) use these to
configure IPv6 addresses on network interfaces and set default routes.
Additionally it listens for IPv6 router solicitation messages and responds
with router advertisements.
rad enabled at boot time, use
“rcctl enable rad”, which sets
rad can be controlled with the
The options are as follows:
radwill run in the foreground and log to stderr.
R. Draves and D. Thaler, Default Router Preferences and More-Specific Routes, RFC 4191, November 2005.
R. Hinden and S. Deering, IP Version 6 Addressing Architecture, RFC 4291, February 2006.
T. Narten, E. Nordmark, W. Simpson, and H. Soliman, Neighbor Discovery for IP version 6 (IPv6), RFC 4861, September 2007.
A. Yourtchenko and L. Colitti, Reducing Energy Consumption of Router Advertisements, RFC 7772, February 2016.
J. Jeong, S. Park, L. Beloeil, and S. Madanapalli, IPv6 Router Advertisement Options for DNS Configuration, RFC 8106, March 2017.
rad program first appeared in
rad program was written by
|November 10, 2019||OpenBSD-6.7|