|PPPX(4)||Device Drivers Manual||PPPX(4)|
— PPP multiplexer device
drivers works with the
npppd(8) daemon to provide
network interfaces for Point-to-Point Protocol (PPP) sessions by request
from the daemon.
pppx operates by allocating a
network interface for each PPP session.
concentrates multiple PPP sessions on a single network interface. The
interfaces also work with
pipex(4) to accelerate the
performance of data packet forwarding, and supports ioctls which are added
npppd(8) the administrator
needs to configure the interface configuration in
npppd.conf(5). Also the
administrator needs to enable
pipex(4) by setting
net.pipex.enable to ‘1’ using
pppx driver first appeared in
OpenBSD 5.3. The
interface driver first appeared in OpenBSD 6.7.
|January 23, 2020||OpenBSD-6.7|