|MIXERCTL.CONF(5)||File Formats Manual||MIXERCTL.CONF(5)|
mixerctl configuration file
mixerctl.conf is the configuration file
for mixerctl(1). It allows
the user to specify settings for the audio mixer at system startup. The
exact set of variables available are largely dependent on the audio device
driver, and vary from device to device. The file is made up of variable
assignments (name=value) with
comments designated by a hash mark (‘#’).
Some audio devices have _sense variables which can help identify connectors. The connectors' state will be one of plugged or unplugged, depending on whether a jack is inserted.
The connectors on audio cards are generally as follows:
Most devices have a number of digital to analogue converters (DACs), used for sound playback, and each DAC has a corresponding output mixer. The mixers are labelled “mix” or “sel”. Each DAC represents two channels of playback.
Verify that playback works by playing an audio file (see
aucat(1)) or CD (see
cdio(1)). Check that any
relevant inputs.* variables are unmuted and set to a high enough value to
permit playback. For example, if playing a CD,
grep(1) for cd variables to
adjust. Check also that the variable governing the general audio level, such
outputs.master, is set to a sufficiently high
Some cards are capable of multi-channel sound. In some cases _dir
variables detail the direction (input or output) of the various connectors.
Check that the direction of the corresponding connectors is set to
output. Other devices may need to set _source
variables to work correctly. The maximum possible value of the
play.channels shows the number of channels
Most devices have a number of analogue to digital converters (ADCs), used for recording sound, and each ADC has a corresponding input mixer. The mixers are labelled “mix” or “sel”. Each ADC represents two channels of recording.
Connect line in on the audio card to an audio source, such as an amplifier. Many devices have an auxiliary connector (“aux”) available for recording, or a headphone socket could be used.
Check that the variable that determines recording volume, such as
record.volume, is set high enough to provide a high
enough sound level, but not so high as to distort the sound being recorded.
It is also a good idea to mute any record.* variables not being used for
recording. Obviously the recording source itself will have to be
A simple test that recording works may be done using aucat(1) whilst playing back audio from an external source. The example below creates a .wav file of any audio being played. The file can then be played back to determine quality.
$ aucat -o test.wav
|July 30, 2018||OpenBSD-6.5|