|AC(8)||System Manager's Manual||AC(8)|
ac — connect time
If the file /var/log/wtmp exists, a record
of individual login and logout times are written to it by
ac examines these records and writes the accumulated
connect time for all logins to the standard output.
The options are as follows:
!’ to indicate not this tty and end with ‘
*’ to indicate all similarly named ttys. Multiple
-tflags may be specified.
If no arguments are given,
ac displays the
total connect time for all accounts with login sessions recorded in
The default wtmp file will increase
without bound unless it is truncated. It is normally truncated by
renames and rotates the wtmp files every week. In
ac to run in sync with the rotation of
newsyslog(8) is configured
to run just after
User accounting information can be mailed weekly to the system administrator: see weekly(8) for more information. No login or connect time accounting is performed if /var/log/wtmp does not exist.
ac utility exits 0 on success,
and >0 if an error occurs.
Allow times recorded in modems to be charged out at a different rate than other:
$ ac -p -t "ttyd*" > modems $ ac -p -t "!ttyd*" > other
ac command appeared in
Version 6 AT&T UNIX. This version of
ac was written for NetBSD
0.9A from the specification provided by various systems' manual
|September 3, 2010||OpenBSD-6.5|