OpenBSD manual page server

Manual Page Search Parameters

VFLUSHBUF(9) Kernel Developer's Manual VFLUSHBUF(9)

vflushbufflush dirty vnode buffers to disk

#include <sys/param.h>
#include <sys/vnode.h>

void
vflushbuf(struct vnode *vp, int sync);

The () function flushes all dirty buffers associated with the vnode vp to the disk. If the sync argument is zero, writes to the disk will be asynchronous and vflushbuf() returns immediately; otherwise, writes will be synchronous and all disk blocks associated with the vnode will have been properly synchronized with the in-core buffers upon return.

vinvalbuf(9), vnode(9)

This document first appeared in OpenBSD 3.7.

June 4, 2013 OpenBSD-6.4