|SAVECORE(8)||System Manager's Manual||SAVECORE(8)|
savecore — save a
core dump of the operating system
savecore copies the currently running
kernel and its associated core dump into directory,
and enters a reboot message and information about the core dump into the
The options are as follows:
savecorewill ignore it.
savecore checks the core dump in various
ways to make sure that it is current and that it corresponds to the
currently running system. If it passes these checks, it saves the core image
in directory/bsd.#.core and
the system in directory/bsd.#
(or in directory/bsd.#.core.Z
respectively, if the
-z option is used). The
“#” is the number from the first line of the file
directory/bounds, and it is
incremented and stored back into the file each time
savecore successfully runs.
savecore also checks the available disk
space before attempting to make the copies. If there is insufficient disk
space in the filesystem containing directory, or if
the file directory/minfree
exists and the number of free kilobytes (for non-superusers) in the
filesystem after the copies were made would be less than the number in the
first line of this file, the copies are not attempted.
savecore successfully copies the kernel
and the core dump, the core dump is cleared so that future invocations of
savecore will ignore it.
savecore is meant to be called near the
end of the initialization file /etc/rc (see
savecore command appeared in
The minfree code does not consider the effect of compression.
|August 14, 2013||OpenBSD-6.4|