|RENICE(8)||System Manager's Manual||RENICE(8)|
renice — alter
priority of running processes
renice alters the scheduling priority of
one or more running processes with ID id. Processes
may be selected by process ID, process group ID, and user name or ID. If
none of the
-gpu options are specified, the default
is to select by process ID. Multiple processes can be specified in a space
Users other than the superuser may only alter the priority of
processes they own, and can only monotonically increase their “nice
value” within the range 0 to
which prevents overriding administrative fiats. The superuser may alter the
priority of any process and set the priority to any value in the range
PRIO_MIN (-20) to
Useful priorities are: 20 (the affected processes will run only when nothing else in the system wants to), 0 (the “base” scheduling priority), anything negative (to make things go very fast).
The options are as follows:
-nis omitted and increment is the first argument to
renice, then increment is taken as an absolute priority rather than an increment.
renice utility exits 0 on
success, and >0 if an error occurs.
The following example changes the priority of process IDs 987 and 32, and all processes owned by users daemon and root:
# renice -n +1 987 -u daemon root -p 32
renice utility is compliant with the
IEEE Std 1003.1-2008 (“POSIX.1”)
specification, except the way in which processes are specified differs.
The historical behavior of passing increment as an absolute priority is supported for backwards compatibility.
renice command appeared in
Non-superusers cannot increase scheduling priorities of their own processes, even if they were the ones that decreased the priorities in the first place.
|May 15, 2015||OpenBSD-6.4|