|INTRO(4)||Device Drivers Manual (alpha)||INTRO(4)|
introduction to special files and hardware
The manual pages in section 4 describe the special files, related driver functions, and networking support available in the system. In this part of the manual, the SYNOPSIS section of each configurable device gives a sample specification for use in constructing a system description for the config(8) program. The DIAGNOSTICS section lists messages which may appear on the console and/or in the system error log /var/log/messages due to errors in device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the system and network related information. The networking support is introduced in netintro(4).
This section describes the hardware supported on the Alpha platform. Software support for these devices comes in two forms. A hardware device may be supported with a character or block device driver, or it may be used within the networking subsystem and have a network interface driver. Block and character devices are accessed through files in the file system of a special type; see mknod(8). Network interfaces are indirectly accessed through the interprocess communication facilities provided by the system; see socket(2).
A hardware device is identified to the system at configuration time and the appropriate device or network interface driver is then compiled into the system. When the resultant system is booted, the autoconfiguration facilities in the system probe for the device and, if found, enable the software support for it. If a device does not respond at autoconfiguration time it is not accessible at any time afterwards. To enable a device which did not autoconfigure, the system will have to be rebooted.
The autoconfiguration system is described in autoconf(4). A list of the supported hardware and devices is given below.
DEC and Compaq have produced a series of the Alpha CPU, some of which are listed below, along with some systems which contain them.
"EV" stands for "Extended VAX" (or "Electro Vlassic") and the number following is a reference to the CMOS process used to make the chips. "LCA" stands for Low Cost Alpha, and "PCA" stands for PC-architecture Alpha.
AlphaPC 64 (EB64)
AlphaStation 200 4/100-166 (Mustang)
AlphaStation 400 4/166 (Chinet)
DEC 3000/300 (150 MHz) (Pelican)
DEC 3000/300X (175 MHz) (Pelican+)
DEC 3000/300L (100 MHz) (Pelica)
DEC 3000/300LX (125 MHz) (Pelica+)
DEC 3000/400 (133 MHz) (Sandpiper)
DEC 3000/600 (175 MHz) (Sandpiper+)
DEC 3000/500 (150 MHz) (Flamingo)
DEC 3000/500X (200 MHz) (Hot Pink)
DEC 3000/800 (200 MHz) (Flamingo II)
DEC 3000/700 (225 MHz) (Sandpiper45)
DEC 3000/900 (275 MHz) (Flamingo45)
AlphaStation 200 4/233 (Mustang+)
AlphaStation 205 4/133-333 (LX3)
AlphaStation 250 4/300 (M3+)
AlphaStation 255 4/133-333 (LX3+)
AlphaStation 300 4/266 (Melmac)
AlphaStation 400 4/233-300 (Avanti)
DEC AXPpci33 (NoName)
Universal Desktop Box AXPpci166MT (UDB/Multia)
21066 evaluation motherboard (EB66)
21066-A evaluation motherboard (EB66+)
Universal Desktop Box AXPpci233MT (UDB/Multia)
21164 evaluation motherboard (EB164)
DigitalServer 3300 (rebadged AlphaServer 800 for NT)
AlphaPC 164SX motherboard (EB164)
PWS 466au (Miata)
PWS 550au (Miata)
APi UP1000 and UP1100; AMD 751-based EV6 systems.
264DP, XP1000, DS10, DS20 Tsunami-based systems.
A complete list of available devices is contained within the pages describing the system buses and controllers. For example, a PCI device would be listed in the pci(4) man page. The following buses and controllers list these devices:
intro first appeared in
|September 19, 2014||OpenBSD-6.4|