OpenBSD manual page server

Manual Page Search Parameters

LOG(9) Kernel Developer's Manual LOG(9)

log, addloglog a message from the kernel through the /dev/klog device

#include <sys/syslog.h>

void
log(int level, const char *format, ...);

void
addlog(const char *format, ...);

The () function allows the kernel to send formatted messages to user processes listening on /dev/klog. Usually syslogd(8) monitors /dev/klog for these messages and writes them to a log file.

All messages are formatted using printf(9), logged using facility LOG_KERN, and priority level level.

The () function is used to build a log message in steps, by adding information to an initial call to log().

syslog(3), syslogd(8), printf(9)

September 14, 2015 OpenBSD-6.4