|IWM(4)||Device Drivers Manual||IWM(4)|
iwm — Intel
7000/8000 IEEE 802.11a/ac/b/g/n wireless network devices
iwm* at pci?
iwm driver provides support for Intel
Wireless 7260, 7265, 3160, 3165, 3168, 8260, and 8265 PCIe Mini Card network
These are the modes the
iwm driver can
iwm driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and
WPA2-PSK). WPA is the current encryption standard for wireless networks. It
is strongly recommended that WEP not be used as the sole mechanism to secure
wireless communication, due to serious weaknesses in it.
The driver needs one of the following firmware files, which are loaded when an interface is brought up:
These firmware files are not free because Intel refuses to grant distribution rights without contractual obligations. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own.
A prepackaged version of the firmware can be installed using fw_update(1).
The following example scans for available networks:
# ifconfig iwm0 scan
The following hostname.if(5) example configures iwm0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
iwm device driver first appeared in
iwm driver does not support any of the
802.11ac capabilities offered by the adapters. Support for 802.11n 40MHz
channels and Tx aggregation is not yet implemented. Additional work is
required in ieee80211(9)
before those features can be supported.
|July 15, 2018||OpenBSD-6.4|