|ISAPNP(4)||Device Drivers Manual||ISAPNP(4)|
introduction to ISA Plug-and-Play support
isapnp0 at isa?
isapnp bus can be configured for each
supported ISA bus.
OpenBSD provides machine-independent bus support and drivers for ISA Plug-and-Play (isapnp) autoconfiguration of PnP-compatible devices on an ISA bus.
OpenBSD includes machine-independent ISAPNP drivers, sorted by function and driver name:
isapnp driver appeared in
From time to time an
isapnp device will be
found which the kernel does not recognize. The kernel matches
isapnp devices to device drivers based on
identifiers which each device provides. For example, this device:
joy0 at isapnp0 "Creative SB16 PnP, CTL7001, PNPB02F, Game" port 0x200/8
This joystick calls itself by the two names “CTL7001” and “PNPB02F”. The latter is a standard name (which the kernel automatically recognizes), but “CTL7001” is a vendor-specific name which needs to be added to a table. Unfortunately, some devices advertise only their vendor-specific name; for instance:
"PnP Sound Chip, @P@1001, , " at isapnp0 port 0x200/8 not configured
Testing will show that this device is actually a joystick. To resolve the issue, the actual name “@P@1001” has to be entered into the database found in /sys/dev/isa/pnpdevs and a new kernel must be built. Then the device will probe like this:
joy0 at isapnp0 "PnP Sound Chip, @P@1001, , " port 0x200/8
|September 3, 2016||OpenBSD-6.4|