|INETD(8)||System Manager's Manual||INETD(8)|
— internet super-server
inetd should be run at boot time by
rc(8)). It then listens for
connections on certain internet sockets. When a connection is found on one
of its sockets, it decides what service the socket corresponds to, and
invokes a program to service the request. After the program is finished, it
continues to listen on the socket (except in some cases which will be
described below). Essentially,
inetd allows running
one daemon to invoke several others, reducing load on the system.
The options are as follows:
inetdwill log the problem and stop servicing requests for the specific service for ten minutes. See also the wait/nowait configuration fields below.
inetd reads its
configuration information from a configuration file which, by default, is
/etc/inetd.conf. There must be an entry for each
field of the configuration file, with entries for each field separated by a
tab or a space. Comments are denoted by a “#” at the beginning
of a line. The fields of the configuration file are as follows:
service name socket type protocol wait/nowait[.max] user[.group] or user[:group] server program server program arguments
To specify a Sun-RPC based service, the entry would contain these fields.
service name/version socket type rpc/protocol wait/nowait[.max] user[.group] or user[:group] server program server program arguments
For internet services, the first field of the
line may also have a host address specifier prefixed to it, separated from
the service name by a colon. If this is done, the string before the colon in
the first field indicates what local address
should use when listening for that service. Multiple local addresses can be
specified on the same line, separated by commas. Numeric IP addresses in
dotted-quad notation can be used as well as symbolic hostnames. Symbolic
hostnames are looked up using
If a hostname has multiple address mappings, inetd creates a socket to
listen on each address.
The single character “*” indicates
INADDR_ANY, meaning “all local
addresses”. To avoid repeating an address that occurs frequently, a
line with a host address specifier and colon, but no further fields, causes
the host address specifier to be remembered and used for all further lines
with no explicit host specifier (until another such line or the end of the
file). A line
The service name entry is the name of a valid service in the file /etc/services. For “internal” services (discussed below), the service name must be the official name of the service (that is, the first entry in /etc/services). When used to specify a Sun-RPC based service, this field is a valid RPC service name in the file /etc/rpc. The part on the right of the “/” is the RPC version number. This can simply be a single numeric argument or a range of versions. A range is bounded by the low version to the high version - “rusers/1-3”. For UNIX-domain sockets this field specifies the path name of the socket.
The socket type should be one of “stream” or “dgram”, depending on whether the socket is a stream or datagram socket.
The protocol must be a valid protocol as given in /etc/protocols. Examples might be “tcp” or “udp”. RPC based services are specified with the “rpc/tcp” or “rpc/udp” service type. “tcp” and “udp” will be recognized as “TCP or UDP over default IP version”. This is currently IPv4, but in the future it will be IPv6. If you need to specify IPv4 or IPv6 explicitly, use something like “tcp4” or “udp6”. A protocol of “unix” is used to specify a socket in the UNIX-domain.
entry is used to tell
inetd if it should wait for
the server program to return, or continue processing connections on the
socket. If a datagram server connects to its peer, freeing the socket so
inetd can receive further messages on the socket, it
is said to be a “multi-threaded” server, and should use the
“nowait” entry. For datagram servers which process all
incoming datagrams on a socket and eventually time out, the server is said
to be “single-threaded” and should use a “wait”
talkd(8) are both examples of
the latter type of datagram server. The optional “max” suffix
(separated from “wait” or “nowait” by a dot)
specifies the maximum number of times a service can be invoked in one
minute; the default is 256. If a service exceeds this limit,
inetd will log the problem and stop servicing
requests for the specific service for ten minutes. See also the
-R option above.
Stream servers are usually marked as “nowait” but if
a single server process is to handle multiple connections, it may be marked
as “wait”. The master socket will then be passed as fd 0 to
the server, which will then need to accept the incoming connection. The
server should eventually time out and exit when no more connections are
inetd will continue to listen on the master
socket for connections, so the server should not close it when it exits.
The user entry should contain the user name of the user as whom the server should run. This allows for servers to be given less permission than root. An optional group name can be specified by appending a dot to the user name followed by the group name. This allows for servers to run with a different (primary) group ID than specified in the password file. If a group is specified and user is not root, the supplementary groups associated with that user will still be set.
The server program entry should contain the
pathname of the program which is to be executed by
inetd when a request is found on its socket. If
inetd provides this service internally, this entry
should be “internal”.
The server program arguments should be just as arguments normally are, starting with argv, which is the name of the program. If the service is provided internally, the word “internal” should take the place of this entry.
inetd provides several
“trivial” services internally by use of routines within
itself. These services are “echo”, “discard”,
“chargen” (character generator), “daytime”
(human readable time), and “time” (machine readable time, in
the form of the number of seconds since midnight, January 1, 1900). All of
these services are TCP based. For details of these services, consult the
appropriate RFC from the Network Information Center.
inetd rereads its configuration file when
it receives a hangup signal,
SIGHUP. Services may be
added, deleted or modified when the configuration file is reread.
If you wish to run a server for IPv4 and IPv6 traffic, you'll need to run two separate processes for the same server program, specified as two separate lines in inetd.conf, for “tcp4” and “tcp6”.
Under various combinations of IPv4/v6 daemon settings,
inetd will behave as follows:
inetd command appeared in
4.3BSD. Support for Sun-RPC based services is
modelled after that provided by SunOS 4.1. IPv6 support was added by the
KAME project in 1999.
Host address specifiers, while they make conceptual sense for RPC services, do not work entirely correctly. This is largely because the portmapper interface does not provide a way to register different ports for the same service on different local addresses. Provided you never have more than one entry for a given RPC service, everything should work correctly. (Note that default host address specifiers do apply to RPC lines with no explicit specifier.)
|October 4, 2017||OpenBSD-6.4|