|DHCRELAY(8)||System Manager's Manual||DHCRELAY(8)|
dhcrelay — Dynamic
Host Configuration Protocol relay agent
dhcrelay utility provides a means for
relaying DHCP and BOOTP requests from a subnet to which no DHCP server is
directly connected to one or more DHCP servers on other subnets.
dhcrelay listens for DHCP requests on a
given interface. When a query is received,
forwards it to the list of DHCP destinations specified on the command line.
When a reply is received, it is broadcast or unicast on the network from
whence the original request came.
The server might be a name, address or interface.
dhcrelay will operate in layer 2 mode when the
specified servers are interfaces, otherwise it will operate in layer 3
The name of at least one DHCP server to which DHCP and BOOTP
requests should be relayed, as well as the name of the network interface
dhcrelay should attempt to configure, must be
specified on the command line.
dhcrelay supports relaying of DHCP traffic
to configure IPsec tunnel mode clients when listening on the
enc(4) interface using layer 3
mode only. The DHCP server has to support RFC 3046 to echo back the relay
agent information to allow stateless DHCP reply to IPsec tunnel mapping.
The options are as follows:
dhcrelayshould append on relayed packets. If this option is not specified it will use the interface number by default.
dhcrelaywill run in the foreground and log to stderr.
dhcrelayshould attempt to configure. For layer 3 mode at least one IPv4 address has to be configured on this interface.
dhcrelayshould append on relayed packets. If this option is not specified it will use the destination address by default.
R. Droms, Dynamic Host Configuration Protocol, RFC 2131, March 1997.
S. Alexander and R. Droms, DHCP Options and BOOTP Vendor Extensions, RFC 2132, March 1997.
M. Patrick, DHCP Relay Agent Information Option, RFC 3046, January 2001.
B. Patel, B. Aboba, S. Kelly, and V. Gupta, Dynamic Host Configuration Protocol (DHCPv4) Configuration of IPsec Tunnel Mode, RFC 3456, January 2003.
dhcrelay was written by
The current implementation was reworked by Henning Brauer <firstname.lastname@example.org>.
|February 15, 2017||OpenBSD-6.4|