|DEV_MKDB(8)||System Manager's Manual||DEV_MKDB(8)|
dev_mkdb — create
dev_mkdb command creates a
hash(3) access method Berkeley
database in “/var/run/dev.db” which
contains the names of all of the character and block special files in the
“/dev” directory, using the file type
and the st_rdev field as the key.
Keys are a structure containing a mode_t followed by a dev_t, with any padding zeroed out. The former is the type of the file (st_mode & S_IFMT), the latter is the st_rdev field.
dev_mkdb command appeared in
|November 30, 2015||OpenBSD-6.4|