OpenBSD manual page server

Manual Page Search Parameters

WS(4) Device Drivers Manual WS(4)

WS - wscons pointer input driver for Xorg on *BSD

Section "InputDevice"
    Identifier "name"
    Driver "ws"
    Option "Buttons" "integer"
    Option "Emulate3Buttons" "boolean"
    Option "Emulate3Timeout" "integer"
    Option "DebugLevel" "integer"
    Option "Device" "path"
    Option "MinX" "integer"
    Option "MaxX" "integer"
    Option "MinY" "integer"
    Option "MaxY" "integer"
    Option "Raw" "boolean"
    Option "Rotate" "string"
    Option "SwapXY" "boolean"
    Option "ZAxisMapping" "N1 N2"
    Option "WAxisMapping" "N1 N2"
EndSection

ws is an XFree86/X.Org input driver for pointer devices (mouse, tablet, touchscreen,...) driven by the wscons console driver on OpenBSD.

This driver supports uts(4), USB touchscreens and ums(4), generic USB mouse devices.

Please refer to xorg.conf(5) for general configuration details and for options that can be used with all input drivers. This section only covers configuration details specific to this driver.

Sets the button mapping for this device. The mapping is a space-separated list of button mappings that correspond in order to the physical buttons on the device (i.e. the first number is the mapping for button 1, etc.). The default mapping is "1 2 3 ... 32". A mapping of 0 deactivates the button. Multiple buttons can have the same mapping. For example, a left-handed mouse with deactivated scroll-wheel would use a mapping of "3 2 1 0 0". Invalid mappings are ignored and the default mapping is used. Buttons not specified in the user's mapping use the default mapping.
Specifies the number of mouse buttons. In cases where the number of buttons cannot be auto-detected, the default value is 3.
Enable/disable the emulation of the middle mouse button for mice which only have two physical buttons. The third button is emulated by pressing both buttons simultaneously. Default: on, until a middle button event is detected.
Sets the timeout (in milliseconds) that the driver waits before deciding if two buttons where pressed "simultaneously" when 3 button emulation is enabled. Default: 50.
Enable/disable "wheel" emulation. Wheel emulation means emulating button press/release events when the mouse is moved while a specific real button is pressed. Wheel button events (typically buttons 4 and 5) are usually used for scrolling. Wheel emulation is useful for getting wheel-like behaviour with trackballs. It can also be useful for mice with 4 or more buttons but no wheel. See the description of the EmulateWheelButton, EmulateWheelInertia, EmulateWheelTimeout, XAxisMapping, and YAxisMapping options. Default: off.
Specifies which button must be held down to enable wheel emulation mode. While this button is down, X and/or Y pointer movement will generate button press/release events as specified for the XAxisMapping and YAxisMapping settings. If the button is 0 and EmulateWheel is on, any motion of the device is converted into wheel events. Default: 4.
Specifies how far (in pixels) the pointer must move to generate button press/release events in wheel emulation mode. Default: 10.
Specifies the time in milliseconds the EmulateWheelButton must be pressed before wheel emulation is started. If the EmulateWheelButton is released before this timeout, the original button press/release event is sent. Default: 200.
This option sets the verbosity level of the driver. It defaults to 0, which means no extra debug output.
sets the path to the special file used by the device, ususally /dev/wsmouse . This option is mandatory.
These options represent the coordinate space returned by the device. They default to the screen dimensions, since the calibration is handled in the kernel by the uts(4) driver and the xtsscale(8) utility.
This option selects the raw (uncalibrated) mode for tablet devices. It defaults to True. When using raw mode, if no coordinate space is specified by the above options, the coordinate space will be read from the kernel calibration data.
These options rotate the screen coordinates returned by the driver clockwise, counter-clockwise, or upside-down respectively.
swaps the X and Y axis of the input device if set. Default: false.
Specifies which buttons are mapped to motion in the X direction in wheel emulation mode. Button number N1 is mapped to the negative X axis motion and button number N2 is mapped to the positive X axis motion. Default: no mapping.
Specifies which buttons are mapped to motion in the Y direction in wheel emulation mode. Button number N1 is mapped to the negative Y axis motion and button number N2 is mapped to the positive Y axis motion. Default: "4 5".
Set the mapping for the Z axis (wheel) motion to buttons. Button number N1 is mapped to the negative Z axis motion and button N2 is mapped to the positive Z axis motion. Default: "4 5".
Set the mapping for the W axis (horizontal wheel) motion to buttons. Button number N1 is mapped to the negative W axis motion and button N2 is mapped to the positive W axis motion. Default: "6 7".

The following properties are provided by the ws driver.

1 boolean value (8 bit, 0 or 1)
1 32-bit positive value (unit: milliseconds)
1 boolean value (8 bit, 0 or 1).
4 8-bit values, order X up, X down, Y up, Y down. 0 disables a value.
1 8-bit value, allowed range 0-32, 0 to always scroll.
1 16-bit positive value.
1 32-bit positive value (unit: milliseconds).
4 32 bits values, in the order min-x, max-x, min-y, max-y. This property is present only for devices with absolute coordinates (ie tablets and touchscreens).
1 boolean value (8 bits, 0 or 1). 1 swaps x/y axes. This property is present only for devices with absolute coordinates (ie tablets and touchscreens).

Xorg(1), xinput(1), xorg.conf(5), ums(4), uts(4), sysctl(8), xtsscale(8).

xf86-input-ws 1.3.0 X Version 11