|RTADVD.CONF(5)||File Formats Manual||RTADVD.CONF(5)|
config file for router advertisement daemon
This file describes how the router advertisement packets must be constructed for each of the interfaces.
As described in
rtadvd(8), you do not have to
set this configuration file up at all, unless you need some special
configurations. You may even omit the file as a whole. In such cases, the
rtadvd daemon will automatically configure itself
using default values specified in the specification.
It obeys the infamous termcap(5) file format. Each line in the file describes a network interface. Fields are separated by a colon (‘:’), and each field contains one capability description. Lines may be concatenated by the ‘\’ character. The comment marker is the ‘#’ character.
Capabilities describe the value to be filled into ICMPv6 router advertisement messages and to control rtadvd(8) behavior. Therefore, you are encouraged to read IETF neighbor discovery documents if you would like to modify the sample configuration file.
Note that almost all items have default values. If you omit an item, the default value of the item will be used.
There are two items which control the interval of sending router
advertisements. These items can be omitted, then
rtadvd will use the default values.
maxinterval. Its value must be no less than 3 seconds and no greater than .75 * the value of
The following items are for ICMPv6 router advertisement message
header. These items can be omitted, then
use the default values.
The default value is 0.
rtadvdruns on a host, this value must explicitly set 0 on all the advertising interfaces as described in rtadvd(8). The default value is 1800.
The following items are for ICMPv6 prefix information option,
which will be attached to router advertisement header. These items can be
rtadvd will automatically get
appropriate prefixes from the kernel's routing table, and advertise the
prefixes with the default parameters, unless the
noifprefix flag is specified. Keywords other than
clockskew can be augmented with a number, like
prefix2”, to specify multiple
rtadvdshould gather prefix information from the interface if no
addris specified. If no
addris given, and
rtadvdwill send RA packets with no prefix information.
The following item is for ICMPv6 MTU option, which will be
attached to router advertisement header. This item can be omitted, then
rtadvd will use the default value.
The following items are for ICMPv6 route information option, which
will be attached to router advertisement header. These items are optional.
Each item can be augmented with a number, like
rtplen2”, to specify multiple
The following items are for ICMPv6 RDNSS option, used to give a list of recursive DNS servers to hosts. If this item is omitted, no information about DNS servers will be advertised.
The following items are used for ICMPv6 DNSSL option which specifies a list of DNS suffixes advertised to hosts. If this option is not specified, no DNS suffix will be sent to hosts.
The following item controls ICMPv6 source link-layer address
option, which will be attached to router advertisement header. As noted
above, you can just omit the item, then
use the default value.
nolladdris not specified), rtadvd(8) will try to get link-layer address for the interface from the kernel, and attach that in source link-layer address option. If this capability exists, rtadvd(8) will not attach source link-layer address option to router advertisement packets.
You can also refer one line from another by using
tc capability. See
termcap(5) for details on
As presented above, all of the advertised parameters have default values defined in specifications, and hence you usually do not have to set them by hand, unless you need special non-default values. It can cause interoperability problem if you use an ill-configured parameter.
To override a configuration parameter, you can specify the
parameter alone. With the following configuration,
rtadvd(8) overrides the
router lifetime parameter for the
The following example manually configures prefixes advertised from
ef0 interface. The configuration must be used
-s option to
The following example configures two recursive DNS servers for the
em0 interface and sets the DNS search suffix to
em0:\ :rdnss="2001:db8:ffff:1000::1,2001:db8:ffff:1000::2":\ :dnssl="example.com":
The following example presents the default values in an explicit manner. The configuration is provided just for reference purposes; YOU DO NOT NEED TO HAVE IT AT ALL.
default:\ :chlim#64:raflags#0:rltime#1800:rtime#0:retrans#0:\ :pinfoflags#192:vltime#2592000:pltime#604800:mtu#0: ef0:\ :addr="2001:db8:ffff:1000::":prefixlen#64:tc=default:
R. Draves and D. Thaler, Default Router Preferences and More-Specific Routes, RFC 4191, 2005.
T. Narten, E. Nordmark, W. Simpson, and H. Soliman, Neighbor Discovery for IP version 6 (IPv6), RFC 4861, 2007.
J. Jeong, S. Park, L. Beloeil, and S. Madanapalli, IPv6 Router Advertisement Options for DNS Configuration, RFC 6106, 2010.
The rtadvd(8) and
the configuration file
rtadvd.conf first appeared in
WIDE Hydrangea IPv6 protocol stack kit.
|March 19, 2018||OpenBSD-6.3|