|RARPD(8)||System Manager's Manual||RARPD(8)|
rarpd — reverse
rarpd services Reverse ARP requests on the
Ethernet connected to the specified interfaces. Upon receiving a request,
rarpd maps the target hardware address to an IP
address via its name, which must be present in both the
hosts(5) databases. If a host
does not exist in both databases, the translation cannot proceed and a reply
will not be sent.
In normal operation,
rarpd forks a copy of
itself and runs in the background. Anomalies and errors are reported via
The options are as follows:
-ais omitted, a list of interfaces must be specified.
rarpdis running on) can "boot" the target; that is, if a file or directory called /tftpboot/ipaddr exists, where ipaddr is the target IP address expressed in uppercase hexadecimal (only the first 8 characters of filenames are checked).
R. Finlayson, T. Mann, J. Mogul, and M. Theimer, A Reverse Address Resolution Protocol, RFC 903, June 1984.
|October 28, 2015||OpenBSD-6.2|