|MD5INIT(9)||Kernel Developer's Manual||MD5INIT(9)|
MD5Transform — message
buf, u_int32_t const
MD5Init module implements the RSA Data
Security, Inc. MD5 Message-Digest Algorithm (MD5). It produces 128-bit MD5
Digest of data.
MD5Transform() will be used to produce a digest. The buf argument is the storage for the digest being produced on subsequent calls to the
The code for MD5 transform was taken from Colin Plumb's implementation, which has been placed in the public domain. The MD5 cryptographic checksum was devised by Ronald Rivest, and is documented in RFC 1321, "The MD5 Message Digest Algorithm".
|November 24, 2015||OpenBSD-6.2|