|gpioctl(8/amd64)||control GPIO devices|
|gpioctl(8/armv7)||control GPIO devices|
|gpioctl(8/i386)||control GPIO devices|
|gpioctl(8/macppc)||control GPIO devices|
|GPIOCTL(8)||System Manager's Manual||GPIOCTL(8)|
gpioctl — control
gpioctl program allows manipulation of
GPIO (General Purpose Input/Output) device pins. Such devices can be either
part of the chipset or embedded CPU, or a separate chip. The usual way of
using GPIO is to connect some simple devices such as LEDs and 1-wire thermal
sensors to its pins.
Each GPIO device has an associated device file in the /dev directory. device can be specified with or without the /dev prefix. For example, /dev/gpio0 or gpio0.
GPIO pins can be either “read” or
“written” with the values of logical 0 or 1. If only a
pin number is specified on the command line, the pin
state will be read from the GPIO controller and displayed. To write to a
pin, a value must be specified after the pin number.
Values can be either
A value of
2 has a special meaning: it
“toggles” the pin, i.e. changes its state to the opposite.
Instead of the numerical values, the word
toggle can be
Only pins that have been configured at securelevel 0, typically
during system startup, are accessible once the securelevel has been raised.
Pins can be given symbolic names for easier use. Besides using individual
pins, device drivers that use GPIO pins can be attached to a
gpio(4) device using the
The following configuration flags are supported by the GPIO framework. Note that not all the flags can be supported by the particular GPIO controller.
When attaching an I2C device, if the flag argument is set to 0x01, the order of the SDA and SCL signals is reversed (see gpioiic(4)).
When executed with only the
gpio(4) device name as
gpioctl reads information about the GPIO
device and displays it. At securelevel 0 the number of physically available
pins is displayed, at higher securelevels the number of configured
set) pins is displayed.
The options are as follows:
Configure pin 20 to have push-pull output:
# gpioctl gpio0 20 set out pp
Write logical 1 to pin 20:
# gpioctl gpio0 20 1
# gpioctl gpio0 attach gpioow 4 0x01
Detach the gpioow0 device:
# gpioctl gpio0 detach gpioow0
Configure pin 5 as output and name it error_led:
# gpioctl gpio0 5 set out error_led
Toggle the error_led:
# gpioctl gpio0 error_led 2
gpioctl command first appeared in
|September 11, 2015||OpenBSD-6.2|