|UMB(4)||Device Drivers Manual||UMB(4)|
umb — USB Mobile
Broadband Interface Model (MBIM)
umb* at uhub?
umb driver provides support for USB
MBIM devices establish connections via cellular networks such as GPRS, UMTS, and LTE. They appear as a regular point-to-point network interface, transporting raw IP frames.
Required configuration parameters like PIN and APN have to be set with ifconfig(8). Once the SIM card has been unlocked with the correct PIN, it will remain in this state until the MBIM device is power-cycled. In case the device is connected to an "always-on" USB port, it may be possible to connect to a provider without entering the PIN again even if the system was rebooted.
The following devices should work:
Universal Serial Bus Communications Class Subclass Specification for Mobile Broadband Interface Model, http://www.usb.org/developers/docs/devclass_docs/MBIM10Errata1_073013.zip.
umb driver does not support IPv6.
Devices which fail to provide a conforming MBIM implementation will probably be attached as some other driver, such as umsm(4).
|November 25, 2016||OpenBSD-6.1|