|TFTPD(8)||System Manager's Manual||TFTPD(8)|
tftpd — DARPA
Trivial File Transfer Protocol daemon
tftpd is a server which implements the
DARPA Trivial File Transfer Protocol.
The use of tftp(1)
does not require an account or password on the remote system. Due to the
lack of authentication information,
tftpd will allow
only publicly readable files to be accessed. Files may be written only if
they already exist and are publicly writable, unless the
-c flag is specified (see below). Note that this
extends the concept of “public” to include all users on all
hosts that can be reached through the network; this may not be appropriate
on all systems, and its implications should be considered before enabling
The server must be started as root, but will chroot to the directory specified on the command line and drop privileges to the _tftpd user.
tftpd always provides random data at the
path /etc/random.seed, and therefore this path will
be ignored inside the directory.
OpenBSD network bootloaders access this path to
harvest entropy during kernel load.
The options are as follows:
tftpdto use IPv4 addresses only.
tftpdto use IPv6 addresses only.
tftpdwill run in the foreground and log the client IP, type of request, and filename to stderr.
tftpdlistens on wildcard addresses.
tftpdlistens on the port indicated in the ‘
tftp’ service description; see services(5).
tftpdwill write lines in the format "IP OP filename", terminated by a newline, where IP is the client's IP address, and OP is one of "read" or "write".
tftpdexpects replies in the format "filename" terminated by a newline. All rewrite requests from the daemon must be answered (even if it is with the original filename) before the TFTP request will continue. By default
tftpddoes not use filename rewriting.
tftpd command was originally a process
run via inetd(8) and appeared
in 4.2BSD. It was rewritten for
OpenBSD 5.2 as a persistent non-blocking daemon.
Many TFTP clients will not transfer files over 16744448 octets (32767 blocks).
|July 18, 2015||OpenBSD-6.1|