OpenBSD manual page server

Manual Page Search Parameters

TAP(4) Device Drivers Manual TAP(4)

tapEthernet tunnel pseudo-device

pseudo-device tun


#include <sys/types.h>
#include <net/if_tun.h>

The tap driver provides an Ethernet interface pseudo-device. Packets sent to this interface can be read by a userland process and processed as desired. Packets written by the userland process are injected back into the kernel networking subsystem.

A tap interface can be created at runtime using the ifconfig tapN create command or by opening the character special device /dev/tapN.

Each device has an exclusive open property: it cannot be opened if it is already open and in use by another process. Each read returns at most one packet; if insufficient buffer space is provided, the packet is truncated. Each write supplies exactly one packet. Each packet read or written is an Ethernet packet. The Ethernet CRC at the end of the frame is not required. On the last close of the device, all queued packets are discarded. If the device was created by opening /dev/tapN, it will be automatically destroyed. Devices created via ifconfig(8) are only marked as not running and traffic will be dropped returning EHOSTDOWN.

Writes never block. If the protocol queue is full, the packet is dropped, a “collision” is counted, and ENOBUFS is returned.

In addition to the usual network interface ioctl commands described in netintro(4), the following special commands defined in <net/if_tun.h> are supported:

struct tuninfo *
 
struct tuninfo *
Get or set the interface characteristics.
/* iface info */
struct tuninfo {
        u_int   mtu;
        u_short type;
        u_short flags;
        u_int   baudrate;
};

flags sets the interface flags, and can include one or more of IFF_UP, IFF_POINTOPOINT, IFF_MULTICAST, IFF_BROADCAST. Flags given will be set; flags omitted will be cleared; flags not in this list will not be changed even when given. Flags default to IFF_BROADCAST | . It is an error to set both IFF_POINTOPOINT and IFF_BROADCAST. type defaults to IFT_ETHER. This sets the interface media address header type.

int *flags
Set just the interface flags. The same restrictions as for TUNSIFINFO apply.

int *flag
Set non-blocking I/O.

int *flag
Cause signal SIGIO to be sent when a packet can be read.

int *pgrp
 
int *pgrp
Get or set the process group to which signals might be sent via FIOASYNC.

int *count
Get the byte count of the next packet available to be read.

struct ether_addr *addr
 
struct ether_addr *addr
Get or set the Ethernet address of the device.

/dev/tap*
 

If open fails, errno(2) may be set to one of:

[]
Not that many devices configured.
[]
Device was already open.

If a write(2) call fails, errno(2) is set to one of:

[]
The packet supplied was too small or too large. The maximum sized packet allowed is currently 16384 bytes.
[]
There were no mbufs, or the queue for the outgoing protocol is full.
[]
The address family specified in the tunnel header was not recognized.

Ioctl commands may fail with:

[]
Attempt to set both IFF_POINTOPOINT and IFF_BROADCAST with TUNSIFMODE.
[]
Unrecognized ioctl command.

A read(2) call may fail because of:

[]
The device is not ready. The device must have an inet(4) interface address assigned to it, such as via SIOCSIFADDR.
[]
Non-blocking I/O was selected and no packets were available.

An attempt to send a packet out via the interface may fail with:

[]
The device is not ready. The device must have an inet(4) interface address assigned to it, such as via SIOCSIFADDR.

inet(4), intro(4), netintro(4), hostname.if(5), ifconfig(8), netstart(8)

October 23, 2015 OpenBSD-6.1