|SETNETBOOTINFO(8)||System Manager's Manual (alpha)||SETNETBOOTINFO(8)|
setnetbootinfoutility configures the OpenBSD/alpha network bootstrap program so that it can be used to bootstrap systems with old firmware revisions. The OpenBSD/alpha network bootstrap program needs to have the Ethernet address of the interface being used to boot the system available when querying other hosts on the network for bootstrapping information. Alpha systems with old firmware revisions provide no way for network bootstrap programs to determine the Ethernet address of the interface that they are booting from, and so the OpenBSD/alpha network bootstrap program must find that information in another way. (Newer firmware revisions include the Ethernet address in the name of the device that is being booted from.) The
setnetbootinfoutility encodes an Ethernet address (and other information) directly into the network bootstrap program. The options recognized by
setnetbootinfoare as follows:
-hoption are mutually exclusive.)
-aoption are mutually exclusive.)
-oflag is not specified, the output file name will be the name of the input bootstrap program concatenated with a period and the digits of the Ethernet address being encoded. For instance, if the input file is named /usr/mdec/netboot and is being configured to encode the Ethernet address
08:00:2b:bd:5d:fd, then the default output file name would be /usr/mdec/netboot.08002bbd5dfd. It is safe to set the output file name to be the same as the input file name; the input file is read in its entirety before the output file is modified.
-ooption, and neither the
-hoptions may be specified.
setnetbootinfocommand first appeared in NetBSD 1.2B.
|February 1, 2009||OpenBSD-6.1|