|NVRAM(4)||Device Drivers Manual (amd64)||NVRAM(4)|
pseudo-device nvram 1
nvramdevice provides read-only access to the non-volatile memory contained in the MC146818 real-time clock. This data is provided as a seekable character device, /dev/nvram. Checksums of the NVRAM contents are calculated over bytes 2 to 31 and stored in byte 32. A valid checksum is required for the driver to initialize.
nvramsupport was originally included in OpenBSD 3.7.
|August 2, 2007||OpenBSD-6.1|