|LOGIN_SKEY(8)||System Manager's Manual||LOGIN_SKEY(8)|
login_skeyutility is called by login(1), su(1), ftpd(8), and others to authenticate the user with S/Key authentication.
The service argument specifies which protocol to use with the invoking program. The allowed protocols are login, challenge, and response. The default protocol is login.
The fd argument is used to specify the number of an open, locked file descriptor that references the user's S/Key entry. This is used to prevent simultaneous S/Key authorization attempts from using the same challenge.
The user argument is the login name of the user to be authenticated.
The optional class argument is accepted for consistency with the other login scripts but is not used.
login_skey will look up
user in the S/Key database and, depending on the
desired protocol, will do one of three things:
If user does not have an entry in the S/Key database, a fake challenge will be generated by the S/Key library.
|February 1, 2012||OpenBSD-6.1|