|gpioctl(8/amd64)||control GPIO devices|
|gpioctl(8/armv7)||control GPIO devices|
|gpioctl(8/i386)||control GPIO devices|
|gpioctl(8/macppc)||control GPIO devices|
|GPIOCTL(8)||System Manager's Manual||GPIOCTL(8)|
] device pin [
] device pin
] device pin
gpioctlprogram allows manipulation of GPIO (General Purpose Input/Output) device pins. Such devices can be either part of the chipset or embedded CPU, or a separate chip. The usual way of using GPIO is to connect some simple devices such as LEDs and 1-wire thermal sensors to its pins. Each GPIO device has an associated device file in the /dev directory. device can be specified with or without the /dev prefix. For example, /dev/gpio0 or gpio0. GPIO pins can be either “read” or “written” with the values of logical 0 or 1. If only a pin number is specified on the command line, the pin state will be read from the GPIO controller and displayed. To write to a pin, a value must be specified after the pin number. Values can be either
1. A value of
2has a special meaning: it “toggles” the pin, i.e. changes its state to the opposite. Instead of the numerical values, the word
togglecan be used. Only pins that have been configured at securelevel 0, typically during system startup, are accessible once the securelevel has been raised. Pins can be given symbolic names for easier use. Besides using individual pins, device drivers that use GPIO pins can be attached to a gpio(4) device using the
gpioctlcommand. The following configuration flags are supported by the GPIO framework. Note that not all the flags can be supported by the particular GPIO controller.
gpioctlreads information about the GPIO device and displays it. At securelevel 0 the number of physically available pins is displayed, at higher securelevels the number of configured (
set) pins is displayed. The options are as follows:
# gpioctl gpio0 20 set out pp
# gpioctl gpio0 20 1
# gpioctl gpio0 attach gpioow 4 0x01
# gpioctl gpio0 detach gpioow0
# gpioctl gpio0 5 set out error_led
# gpioctl gpio0 error_led 2
gpioctlcommand first appeared in OpenBSD 3.6.
gpioctlprogram was written by Alexander Yurchenko <email@example.com>. Device attachment was added by Marc Balmer <firstname.lastname@example.org>.
|September 11, 2015||OpenBSD-6.1|