|FINGERD(8)||System Manager's Manual||FINGERD(8)|
fingerd — remote
user information server
fingerd implements a simple protocol based
on RFC 1288 that provides an interface to the Name and Finger programs at
several network sites. The program is supposed to return a friendly,
human-oriented status report on either the system at the moment or a
particular person in depth. There is no required format and the protocol
consists mostly of specifying a single “command line”.
fingerd is started by
inetd(8), which listens for
TCP requests at port 79. Once connected it reads a single command line
terminated by a ⟨CRLF⟩ which is passed to
fingerd closes its connections as soon as the output
If the line is null (i.e., just a ⟨CRLF⟩ is sent) then finger(1) returns a “default” report that lists all people logged into the system at that moment.
If a user name is specified (e.g., eric⟨CRLF⟩) then the response lists more extended information for only that particular user, whether logged in or not. Allowable “names” in the command line include both “login names” and “user names”. If a name is ambiguous, all possible derivations are returned.
The following options may be passed to
fingerd as server program arguments in
-moption is supplied.
fingerdis finger(1). By specifying a customized local server, this option allows a system manager to have more control over what information is provided to remote sites.
D. Zimmerman, The Finger User Information Protocol, RFC 1288, December 1991.
fingerd command appeared in
|January 15, 2015||OpenBSD-6.1|