|DHCRELAY(8)||System Manager's Manual||DHCRELAY(8)|
dhcrelayutility provides a means for relaying DHCP and BOOTP requests from a subnet to which no DHCP server is directly connected to one or more DHCP servers on other subnets.
dhcrelaylistens for DHCP requests on a given interface. When a query is received,
dhcrelayforwards it to the list of DHCP destinations specified on the command line. When a reply is received, it is broadcast or unicast on the network from whence the original request came. The server might be a name, address or interface.
dhcrelaywill operate in layer 2 mode when the specified servers are interfaces, otherwise it will operate in layer 3 mode. The name of at least one DHCP server to which DHCP and BOOTP requests should be relayed, as well as the name of the network interface that
dhcrelayshould attempt to configure, must be specified on the command line.
dhcrelaysupports relaying of DHCP traffic to configure IPsec tunnel mode clients when listening on the enc(4) interface using layer 3 mode only. The DHCP server has to support RFC 3046 to echo back the relay agent information to allow stateless DHCP reply to IPsec tunnel mapping. The options are as follows:
dhcrelayshould append on relayed packets. If this option is not specified it will use the interface number by default.
dhcrelaywill run in the foreground and log to stderr.
dhcrelayshould attempt to configure. For layer 3 mode at least one IPv4 address has to be configured on this interface.
dhcrelayshould append on relayed packets. If this option is not specified it will use the destination address by default.
dhcrelaywas written by Ted Lemon <email@example.com>. The current implementation was reworked by Henning Brauer <firstname.lastname@example.org>. dhcpd(8) and dhclient(8),
dhcrelaywill bypass IPsec for all its traffic.
|February 15, 2017||OpenBSD-6.1|