|CRON(8)||System Manager's Manual||CRON(8)|
crondaemon schedules commands to be run at specified dates and times. Commands that are to be run periodically are specified within crontab(5) files. Commands that are only to be run once are scheduled via the at(1) and batch(1) commands. Normally, the
crondaemon is started from the /etc/rc command script. Because it can execute commands on a user's behalf,
cronshould be run late in the startup sequence, as close to the time when logins are accepted as possible.
at(1) files when it starts up and
also when changes are made via the
at(1) commands. Additionally,
cron checks the modification time on the system
crontab file (/etc/crontab), the crontab spool
(/var/cron/tabs), and the at spool
(/var/cron/atjobs) once a minute. If the
modification time has changed, the affected files are reloaded.
Any output produced by a command is sent to the user specified in
MAILTO environment variable as set in the
crontab(5) file or, if no
MAILTO variable is set (or if this is an
batch(1) job), to the job's
owner. If a command produces no output or if the
MAILTO environment variable is set to the empty
string, no mail will be sent. The exception to this is
batch(1) jobs submitted with
-m flag. In this case, mail will be sent even if
the job produces no output.
If time has moved forward, those jobs that would have run in the interval that has been skipped will be run immediately. Conversely, if time has moved backward, care is taken to avoid running jobs twice.
Time changes of more than 3 hours are considered to be corrections to the clock or time zone, and the new time is used immediately.
The options are as follows:
cronwill detach from the current tty and become a daemon. The
-noption disables this behavior and causes it to run in the foreground.
|November 12, 2015||OpenBSD-6.1|