|CHOWN(8)||System Manager's Manual||CHOWN(8)|
:group] file ...
] :group file ...
chownsets the user ID and/or the group ID of the specified files. The options are as follows:
-Roption is specified, symbolic links on the command line are followed. Symbolic links encountered in the tree traversal are not followed.
-Roptions are mutually exclusive.
-Roption is specified, all symbolic links are followed.
-Roption is specified, no symbolic links are followed.
-Poptions are ignored unless the
-Roption is specified; if none of them are given, the default is to not follow symbolic links. In addition, these options override each other and the command's actions are determined by the last one specified. The owner and group operands are both optional; however, one must be specified. If the group operand is specified, it must be preceded by a colon (‘:’) character. The owner may be either a numeric user ID or a user name. If a user name is also a numeric user ID, the operand is used as a user name. The group may be either a numeric group ID or a group name. If a group name is also a numeric group ID, the operand is used as a group name. By default,
chownclears the set-user-ID and set-group-ID bits on the file to prevent accidental or mischievous creation of set-user-ID and set-group-ID programs. This behaviour can be overridden by setting the sysctl(8) variable fs.posix.setuid to zero. Only the superuser is permitted to change the owner of a file.
chownutility exits 0 on success, and >0 if an error occurs. chgrp(1), find(1), chown(2), fts(3), symlink(7)
chownutility is compliant with the IEEE Std 1003.1-2008 (“POSIX.1”) specification. The ability to specify group without owner is an extension to that specification. Some non-BSD systems may allow the (non-privileged) owner of a file to change its ownership. Previous versions of the
chownutility used the dot (‘.’) character to distinguish the group name. This has been changed to be a colon (‘:’) character so that user and group names may contain the dot character.
|December 31, 2015||OpenBSD-6.1|