OpenBSD manual page server

Manual Page Search Parameters

AMDMSR(4) Device Drivers Manual (i386) AMDMSR(4)

amdmsraccess MSRs on certain AMD Geode LX systems

amdmsr0 at mainbus?

The amdmsr device provides access to the Model Specific Registers (MSRs) on systems with an AMD Geode LX CPU and graphics processor.

MSRs can be read or written via () calls performed on /dev/amdmsr. Declarations and data types are to be found in <machine/amdmsr.h>.

Read or write requests are performed using:

struct amdmsr_req {
	u_int32_t addr;	/* 32-bit MSR address */
	u_int64_t val;	/* 64-bit MSR value */
};

The RDMSR ioctl is used to read an MSR register.

The WRMSR ioctl is used to write an MSR register.

ioctl(2)

amdmsr support was added in OpenBSD 4.4.

January 21, 2014 OpenBSD-6.1