|tvtwo(4/sparc)||accelerated 24-bit color frame buffer|
|tvtwo(4/sparc64)||accelerated 24-bit color frame buffer|
|TVTWO(4)||Device Drivers Manual (sparc)||TVTWO(4)|
accelerated 24-bit color frame buffer
tvtwo* at sbus?
wsdisplay* at tvtwo?
The Parallax XVideo and PowerVideo frame buffers, also known as ‘tvtwo’, are memory based color frame buffers, with graphics acceleration and overlay capabilities, and hardware MPEG decoding.
tvtwo driver interfaces the frame
buffer to the wscons(4)
console framework. It does not provide direct device driver entry points but
makes its functions available via the internal
The XVideo and PowerVideo frame buffers will adapt their resolution and refresh rate to the monitor they are connected to. However, when not connected to a Sun monitor, the device will default to the cgthree(4)-compatible 1152x900 resolution, with a refresh rate of 67Hz. A different resolution can be forced using the rotary switch on the edge of the board.
The available modes are as follows:
All other rotary positions will behave as position 0, except for positions E and F. Position E enables the board built-in debugger on the serial port, and should not be used by end-users. Position F selects the video mode settings stored in the cards NVRAM. These settings cannot be modified under OpenBSD.
This driver does not support any acceleration features at the moment.
Storing video mode information in the NVRAM is not supported.
|December 3, 2011||OpenBSD-6.0|