|PKG.CONF(5)||File Formats Manual||PKG.CONF(5)|
system-wide package system configuration
The file /etc/pkg.conf contains system-wide options related to package handling, as a list of ‘keyword=value’ lines.
In particular, the base system “installation-and-update” shell scripts record the URL used for the installation as installpath. pkg_add(1) can then add or replace packages from the same location straight after the install.
Currently defined options are as follows:
PKG_PATHis not defined and no further options are defined.
Special sequences ‘%a’, ‘%c’, ‘%m’, ‘%v’ will be expanded to ‘package architecture’, ‘OS version or snapshots’, ‘full mirror path’ and ‘OS version’ respectively. If a bare hostname is given, the standard /pub/OpenBSD path will be used automatically, e.g.
installpath = http://somesite.example.org/updates/%c/%a/ installpath += openbsd-mirror.example.org
Each option uses a separate line, and follows the following template:
keyword = value
A list of values can also be specified over several lines using the variation:
keyword += value keyword += value ...
Keywords are case-insensitive.
Blank lines and comment lines (introduced by a #) are ignored.
Unknown keywords are ignored.
pkg.conf mechanism and format first
appeared in OpenBSD 4.8.
|January 27, 2016||OpenBSD-6.0|