|CHOWN(8)||System Manager's Manual||CHOWN(8)|
chown — change
file owner and group
chown sets the user ID and/or the group ID
of the specified files.
The options are as follows:
-Roption is specified, symbolic links on the command line are followed. Symbolic links encountered in the tree traversal are not followed.
-Roptions are mutually exclusive.
-Roption is specified, all symbolic links are followed.
-Roption is specified, no symbolic links are followed.
-P options are ignored unless the
-R option is specified; if none of them are given,
the default is to not follow symbolic links. In addition, these options
override each other and the command's actions are determined by the last one
The owner and group operands are both optional; however, one must be specified. If the group operand is specified, it must be preceded by a colon (‘:’) character.
The owner may be either a numeric user ID or a user name. If a user name is also a numeric user ID, the operand is used as a user name. The group may be either a numeric group ID or a group name. If a group name is also a numeric group ID, the operand is used as a group name.
chown clears the set-user-ID
and set-group-ID bits on the file to prevent accidental or mischievous
creation of set-user-ID and set-group-ID programs. This behaviour can be
overridden by setting the
fs.posix.setuid to zero.
Only the superuser is permitted to change the owner of a file.
chown utility exits 0 on
success, and >0 if an error occurs.
chown utility is compliant with the
IEEE Std 1003.1-2008 (“POSIX.1”)
The ability to specify group without owner is an extension to that specification.
Some non-BSD systems may allow the (non-privileged) owner of a file to change its ownership.
Previous versions of the
used the dot (‘.’) character to distinguish the group name.
This has been changed to be a colon (‘:’) character so that
user and group names may contain the dot character.
|December 31, 2015||OpenBSD-6.0|