|CGFOURTEEN(4)||Device Drivers Manual (sparc)||CGFOURTEEN(4)|
accelerated 8/24-bit color frame buffer
cgfourteen0 at obio0 addr 0x9c000000
(SS10SX and SS20)
cgfourteen1 at obio0 addr 0x90000000 (SS10SX and SS20)
wsdisplay* at cgfourteen?
cgfourteen is the on-board color frame
buffer, with graphics acceleration and overlay capabilities, found on the
SPARCstation 10SX and SPARCstation 20 workstations. The frame buffer will
not be enabled unless a VSIMM memory module is installed.
The second frame buffer will also require an ‘Auxiliary Video Board’ to be installed.
cgfourteen driver interfaces the frame
buffer with the wscons(4)
console framework. It does not provide direct device driver entry points but
makes its functions available via the internal
cgfourteen frame buffer is used as
the console display, a different resolution than the default 1152x900 can be
selected by changing the OpenPROM environment. To change the default
resolution, type the following:
ok setenv output-device screen:r1280x1024x66
to change to a 66Hz 1280x1024 resolution.
buffer is a secondary display, or a serial console is used, the display
resolution cannot be changed without using an
script. Refer to the
Sun Frame Buffer
FAQ for details.
cgfourteen frame buffer accepts the
The following video modes are supported by the hardware, but not by Sun.
Resolutions of 1280x1024, 1600x1280 and 1920x1080 are 8-bit only with 4MB VSIMM.
Sun Frame Buffer FAQ, http://www.sunhelp.org/faq/FrameBuffer.html.
|November 1, 2015||OpenBSD-6.0|