OpenBSD manual page server

Manual Page Search Parameters

VCLEAN(9) Kernel Developer's Manual VCLEAN(9)

vcleandisassociate the underlying file system from a vnode

#include <sys/param.h>
#include <sys/vnode.h>

void
vclean(struct vnode *vp, int flags, struct proc *p);

The () function clears any VM and buffer data associated with the vnode vp and reclaims it from the underlying file system.

Its arguments are:

vp
The vnode to be cleaned.
flags
The flags indicating how the vnode should be handled.
If this flag is set, () will call vinvalbuf(9) on the vnode. If the vnode is active, it will be closed and inactivated in the underlying file system.
p
The process responsible for this call.

On exit, the v_tag field of the vnode will be set to VT_NON, and if the vnode was active, it will be placed on the vnode free list.

vinvalbuf(9), vnode(9)

This man page was originally written for OpenBSD.

June 4, 2013 OpenBSD-5.9