|TRUNK(4)||Device Drivers Manual||TRUNK(4)|
trunk — link
aggregation and link failover interface
trunk interface allows aggregation of
multiple network interfaces as one virtual
trunk interface can be created using the
create command. It can use different link
aggregation protocols specified using the
proto option. Child interfaces can be added using the
trunkport child-iface option
and removed using the
The driver currently supports the trunk protocols
default). The protocols determine which ports are used for outgoing traffic
and whether a specific port accepts incoming traffic. The interface link
state is used to validate if the port is active or not.
Create a simple round robin trunk with two bge(4) Gigabit Ethernet interfaces:
# ifconfig bge0 up # ifconfig bge1 up # ifconfig trunk0 trunkport bge0 trunkport bge1 \ 192.168.1.1 netmask 255.255.255.0
The following example uses an active failover trunk to set up roaming between wired and wireless networks using two network devices. Whenever the wired master interface is unplugged, the wireless failover device will be used:
# ifconfig em0 up # ifconfig ath0 nwid my_net up # ifconfig trunk0 trunkproto failover trunkport em0 trunkport ath0 \ 192.168.1.1 netmask 255.255.255.0
trunk device first appeared in
trunk driver was written by
The trunk protocols
roundrobin require a switch which supports IEEE
802.3ad static link aggregation; otherwise protocols such as
inet6(4) duplicate address
detection (DAD) cannot properly deal with duplicate packets.
There is no way to configure LACP administrative variables, including system and port priorities. The current implementation always performs active-mode LACP and uses 0x8000 as system and port priorities.
trunk interface takes its MTU from the
trunkport. To avoid mismatches, adding a child
interface with a different MTU is not permitted.
|March 13, 2015||OpenBSD-5.9|