OpenBSD manual page server

Manual Page Search Parameters

MK.CONF(5) File Formats Manual MK.CONF(5)

mk.confsystem-specific configuration parameters

.include <bsd.own.mk>

To get system-specific configuration parameters, ⟨bsd.own.mk⟩ will try to include the file specified by the MAKECONF variable. If MAKECONF is not set, or no such file exists, the system make configuration file /etc/mk.conf is included, if it exists. By default, this file does not exist, and must be created from scratch. For more information on how the make process works, and details of the format of make files, see make(1).

⟨bsd.own.mk⟩ is generally useful when building Makefiles, so that they use the same default owners, etc. as the rest of the tree. These files may define any of the variables described below. Additionally, see bsd.port.mk(5) for a list of variables that can be set by the ports(7) subsystem.

The following variables are set by ⟨bsd.own.mk⟩, if they are not already defined. Defaults are in brackets.

Binary group. [bin]
Binary mode. [555]
Binary owner. [root]
The real path to the system 'obj' tree, so that 'make obj' will work correctly. [/usr/obj]
The real path to the system sources, so that 'make obj' will work correctly. [/usr/src]
Mode for new directories. [755]
Base path for system documentation installation. [/usr/share/doc]
Documentation group. [bin]
Documentation mode. [${NONBINMODE}]
Documentation owner. [root]
The old usage of this flag is obsolescent, since install(1) now copies by default. However, it can also be used to specify that a file not be copied unless it is different (via the -p option). See install(1) for details. This is to be used when building an install script so that the entire system can either be installed with copies, or copy-if-different using a single knob. [-c]
The flag passed to the install program to cause the binary to be stripped. This is to be used when building an install script so that the entire system can be made stripped/not-stripped using a single knob. Note that INSTALL_STRIP is not set if ${DEBUG} is defined. [-s]
Base path for library installation. [/usr/lib]
Library group. [${BINGRP}]
Library mode. [${NONBINMODE}]
Library owner. [${BINOWN}]
Base path for manual installation. [/usr/share/man/man]
Manual group. [bin]
Manual mode. [${NONBINMODE}]
Manual owner. [root]
Mode for non-executable files. [444]
The real path to the 'obj' tree for building the X Window System. [/usr/xobj]
The real path to the X Window System sources. [/usr/xenocara]

Additionally, the following variables may be set by ⟨bsd.own.mk⟩ or in a make configuration file to modify the behaviour of the system build process (default values are in brackets along with comments, if set by ⟨bsd.own.mk⟩):

Add -g to assembly, C compiler and linking passes. Also doesn't set INSTALL_STRIP to -s per default if defined.
Create libraries with -g debug information, and install them in /usr/lib/debug.
Set to the name of a file that all cached GNU autoconf test results will be saved in. Reduces redundant tests. Be careful! Redundant tests may not be redundant when installing substantially updated GNU programs. [yes]
Do not build shared libraries.
Do not build PIE objects or executables.
Do not build profiled versions of system libraries.
If set to "-pipe", gcc(1) will be given the -pipe option which can speed up compiles on machines with memory to spare. Instead of using temp files, gcc(1) uses pipes for the temporary data.
Compile in support for S/key authentication. [yes; set unconditionally]
A space separated list of directories, relative to BSDSRCDIR, to be skipped during "make build".
Command run by make(1) when doing certain operations requiring root privileges (e.g. the "make install" portion of "make build"). If set to /usr/bin/doas, this allows one to run "make build" as a user other than root (assuming doas is set up for that user).
Copy or symlink kernel include files into /usr/include. Possible values are "symlinks" or "copies" (which is the same as the variable being unset).
Adds appropriate warning flags (defined in CDIAGFLAGS, e.g. -Wall...) to compiles. [no]
Build X with Direct Rendering Infrastructure (DRI) support, providing some hardware acceleration. This is on by default for amd64/i386 architectures.
Forces X builds to re-run automake and autoconf in each module before configuring them. This option requires that the automake, autoconf and libtool packages are installed. [no]

/etc/mk.conf
System make configuration file.
/usr/share/mk/*
System include make files.

make(1), bsd.port.mk(5), ports(7)

The mk.conf manual page first appeared in OpenBSD 3.4.

October 26, 2015 OpenBSD-5.9