|KGDB(7)||Miscellaneous Information Manual||KGDB(7)|
kgdb — remote
kernel debugging with gdb
Should a programmer be dissatisfied with the
OpenBSD kernel's internal debugger
ddb(4), and have appropriate
hardware available, a kernel with
option KGDB may be
built to effect remote debugging with
To prepare for debugging over serial line one would:
kgdbat this point.
gdb info documents and online documentation.
The remote connection will introduce certain latencies a local debugger would not see.
Not available on all architectures.
|May 31, 2007||OpenBSD-5.9|