|HOSTS(5)||File Formats Manual||HOSTS(5)|
hosts — host name
hosts file contains information
regarding the known hosts on the network. For each host, a single line
should be present with the following information:
Internet address Official host name Aliases
Items are separated by any number of blanks and/or tab characters.
#’ indicates the beginning of a
comment; characters up to the end of the line are not interpreted by
routines which search the file.
The system configuration file
where host name information will be searched for. The mechanism provided
permits the administrator to describe the databases to search; the databases
currently known include yp(8),
DNS and the
When using a name server this file provides a backup when the name server is not running. For the name server, it is suggested that only a few addresses be included in this file. These include addresses for the local interfaces that ifconfig(8) needs at boot time and a few machines on the local network.
Internet addresses are specified using either dot notation (IPv4) or colon separated notation (IPv6). Further information on network addressing is contained in inet_addr(3). Host names may contain any printable character other than a field delimiter, newline, or comment character.
hosts file format appeared in
An official host database used to be maintained at the Network Information Control Center (NIC).
A name server should be used instead of a static file.
Lines in /etc/hosts are limited to
BUFSIZ characters (currently 1024). Longer lines
will be ignored.
|August 23, 2014||OpenBSD-5.9|