|BOOT_LUNA88K(8)||System Manager's Manual (luna88k)||BOOT_LUNA88K(8)|
luna88k system bootstrapping procedures
When powered on, or after a system reboot, the luna88k ROM monitor will proceed to its initialization, and will boot the operating system configured in nvram if autoboot is enabled.
The behaviour of the ROM monitor, as well as some kernel options, are controlled through the SW1 set of DIP switches on the front panel.
The switch positions are not the same on LUNA-88K and LUNA-88K2 models. On LUNA-88K, a switch is enabled when in the down position, while on the LUNA-88K2, a switch is enabled when in the up position.
The following SW1 switches alter the ROM monitor behaviour:
||interact with ROM monitor||auto-boot|
||serial console||graphics console|
The following switches alter the kernel behaviour:
||boot in single-user mode||boot in multi-user mode|
||prompt for root device||do not prompt for root device|
||enter UKC mode||do not enter UKC mode|
For more details about the “User Kernel Configuration” mode (UKC), see boot_config(8).
Note that the first switch controls both the kernel and the ROM monitor behaviour.
In case of system crashes, the kernel will usually enter the kernel debugger, ddb(4), unless it is not present in the kernel, or it is disabled via the ddb.panic sysctl. Upon leaving ddb, or if ddb was not entered, the kernel will halt the system if it was still in device configuration phase, or attempt a dump to the configured dump device, if possible. The crash dump will then be recovered by savecore(8) during the next multi-user boot cycle. It is also possible to force other behaviours from ddb.
|May 24, 2014||OpenBSD-5.9|