OpenBSD manual page server

Manual Page Search Parameters

VPUT(9) Kernel Developer's Manual VPUT(9)

vputdecrement the reference count for a vnode and unlock it

#include <sys/param.h>
#include <sys/vnode.h>

void
vput(struct vnode *vp);

Decrement the v_usecount field of the vnode vp and unlock the vnode.

This operation is functionally equivalent to calling VOP_UNLOCK(9) followed by vrele(9).

vnode(9), VOP_UNLOCK(9), vref(9), vrele(9)

This man page was originally written by Doug Rabson for FreeBSD.

August 14, 2013 OpenBSD-5.8