|RANDOM(4)||Device Drivers Manual||RANDOM(4)|
— random data source devices
random devices produce high
quality random output data. Entropy data is collected from system activity
(such as disk, network, and clock device interrupts), and then used to key
the ChaCha stream cipher to generate the output. All the random devices are
expected to provide high quality pseudo-random output data.
The arc4random(3) function in userland libraries should be used instead, as it works without the need to access these devices every time.
random device first appeared in the
Linux operating system. This is a cloned interface.
ARC4 routines added by David Mazieres. Changed to use the ChaCha cipher in OpenBSD 5.5.
No randomness testing suite provided.
|January 23, 2014||OpenBSD-5.8|