|LOGIN_TIS(8)||System Manager's Manual||LOGIN_TIS(8)|
login_tisutility is called by login(1), su(1), ftpd(8), and others to authenticate the user via the TIS “Firewall Toolkit” authentication server (authsrv), optionally using DES encryption.
The service argument specifies which protocol to use with the invoking program. The allowed protocols are login, challenge, and response. The default protocol is login.
The fd argument is used to specify the number of an open file descriptor connected to authsrv. This allows a persistent connection to be used for separate challenge and response authentication.
The user argument is the login name of the user to be authenticated.
The class argument is the login class of the user to be authenticated and is used to look up /etc/login.conf variables (see below). It is also sent to authsrv for logging purposes. If no class argument is specified, the class will be obtained from the password database.
login_tis will connect to
authsrv and, depending on the desired protocol, will do
one of three things:
login_tisutility uses the following TIS-specific /etc/login.conf variables:
|January 15, 2015||OpenBSD-5.8|