OpenBSD manual page server

Manual Page Search Parameters

COPY(9) Kernel Developer's Manual COPY(9)

copykernel copy functions

#include <sys/types.h>
#include <sys/systm.h>

int
copyin(const void *uaddr, void *kaddr, size_t len);

int
copyout(const void *kaddr, void *uaddr, size_t len);

int
copystr(const void *kfaddr, void *kdaddr, size_t len, size_t *done);

int
copyinstr(const void *uaddr, void *kaddr, size_t len, size_t *done);

int
copyoutstr(const void *kaddr, void *uaddr, size_t len, size_t *done);

int
kcopy(const void *kfaddr, void *kdaddr, size_t len);

The copy functions are designed to copy contiguous data from one address to another. All but () and () copy data from user-space to kernel-space or vice-versa.

The copy routines provide the following functionality:

()
Copies len bytes of data from the user-space address uaddr to the kernel-space address kaddr.
()
Copies len bytes of data from the kernel-space address kaddr to the user-space address uaddr.
copystr()
Copies a null-terminated string, at most len bytes long, from kernel-space address kfaddr to kernel-space address kdaddr. The number of bytes actually copied, including the terminating null, is returned in *done, if done is not NULL.

Unlike the other copy functions, () does support returning EFAULT when a bad address is encountered.

()
Copies a null-terminated string, at most len bytes long, from user-space address uaddr to kernel-space address kaddr. The number of bytes actually copied, including the terminating null, is returned in *done, if done is not NULL.
()
Copies a null-terminated string, at most len bytes long, from kernel-space address kaddr to user-space address uaddr. The number of bytes actually copied, including the terminating null, is returned in *done, if done is not NULL.
kcopy()
Copies len bytes of data from the kernel-space address kfaddr to the kernel-space address kdaddr.

The copy functions return 0 on success or EFAULT if a bad address is encountered. In addition, the copystr(), copyinstr(), and copyoutstr() functions return ENAMETOOLONG if the string is longer than len bytes.

June 4, 2013 OpenBSD-5.8