|BOOTPARAMD(8)||System Manager's Manual||BOOTPARAMD(8)|
rpc.bootparamd — boot
bootparamd is a server process that
provides information to diskless clients necessary for booting. It consults
the file /etc/bootparams. It should normally be
started from /etc/rc.
This version will allow the use of aliases on the hostname in the /etc/bootparams file. The hostname returned in response to the booting client's whoami request will be the name that appears in the config file, not the canonical name. In this way you can keep the answer short enough so that machines that cannot handle long hostnames won't fail during boot.
While parsing, if a line containing just “+” is found, and the YP subsystem is active, the YP map bootparams will be searched immediately.
The options are as follows:
Originally written by Klas Heggemann <email@example.com>.
You may find the syslog loggings too verbose.
It's not clear if the non-canonical hack mentioned above is a good idea.
rpc.bootparamd is run on a system which
is also running YP, your YP domainname will be made public information.
|July 16, 2013||OpenBSD-5.8|