|SUDO(8)||System Manager's Manual||SUDO(8)|
— execute a command as another user
sudo allows a permitted user to execute a
command as the superuser or another user, as specified
by the sudoers file. The real and effective uid and gid
are set to match those of the target user, as specified in the password
database, and the group vector is initialized based on the group database
-P option was specified). See the
Command Environment section
below for more details.
sudo determines who is an authorized user
by consulting the file /etc/sudoers. By running
sudo with the
-v option, a
user can update the time stamp without running a
command. If authentication is required,
sudo will exit if the user's password is not entered
within a configurable time limit. The default password prompt timeout is
When invoked as
-e option (described below), is implied.
The options are as follows:
sudorequires a password, it will read it from the user's terminal. If the
-A(askpass) option is specified, a (possibly graphical) helper program is executed to read the user's password and output the password to the standard output. If the
SUDO_ASKPASSenvironment variable is set, it specifies the path to the helper program. Otherwise, the value specified by the askpass option in sudoers(5) is used. If no askpass program is available,
sudowill exit with an error.
-a(authentication type) option causes
sudoto use the specified authentication type when validating the user, as allowed by /etc/login.conf. The system administrator may specify a list of sudo-specific authentication methods by adding an “auth-sudo” entry in /etc/login.conf. This option is only available on systems that support BSD authentication.
-b(background) option tells
sudoto run the given command in the background. Note that if you use the
-boption you cannot use shell job control to manipulate the process. Most interactive commands will fail to work properly in background mode.
sudowill close all open file descriptors other than standard input, standard output and standard error. The
-C(close from) option allows the user to specify a starting point above the standard error (file descriptor three). Values less than three are not permitted. This option is only available when the administrator has enabled the closefrom_override option in sudoers(5).
-c(class) option causes
sudoto run the command with resource limits and scheduling priority of the specified login class. The class argument can be either a class name as defined in /etc/login.conf, or a single ‘
-’ character. If class is
-, the default login class of the target user will be used. Otherwise, the command must be run as the superuser (user ID 0), or
sudomust be run from a shell that is already running as the superuser. If the command is being run as a login shell, additional /etc/login.conf settings, such as the umask and environment variables, will be applied, if present. This option is only available on systems with BSD login classes.
-E(preserve environment) option will override the env_reset option in sudoers(5). It is only available when either the matching command has the
SETENVtag or the setenv option is set in sudoers(5).
sudowill return an error if the
-Eoption is specified and the user does not have permission to preserve the environment.
-e(edit) option indicates that, instead of running a command, the user wishes to edit one or more files. In lieu of a command, the string "sudoedit" is used when consulting the sudoers file. If the user is authorized by sudoers, the following steps are taken:
EDITORenvironment variables (in that order) is run to edit the temporary files. If none of
EDITORare set, the first program listed in the editor sudoers(5) option is used.
If the specified file does not exist, it will be created. Note
that unlike most commands run by sudo, the editor is
run with the invoking user's environment unmodified. If, for some
sudo is unable to update a file with its
edited version, the user will receive a warning and the edited copy will
remain in a temporary file.
sudoruns a command with the primary group set to the one specified by the password database for the user the command is being run as (by default, root). The
-g(group) option causes
sudoto run the command with the primary group set to group instead. To specify a gid instead of a group name, use #gid. When running commands as a gid, many shells require that the ‘
#’ be escaped with a backslash (‘
\’). If no
-uoption is specified, the command will be run as the invoking user (not root). In either case, the primary group will be set to group.
-H(HOME) option option sets the
HOMEenvironment variable to the home directory of the target user (root by default) as specified by the password database. The default handling of the
HOMEenvironment variable depends on sudoers(5) settings. By default,
sudowill not modify
HOME(see set_home and always_set_home in sudoers(5)).
-h(help) option causes
sudoto print a short help message to the standard output and exit.
-i(simulate initial login) option runs the shell specified by the password database entry of the target user as a login shell. This means that login-specific resource files such as .profile or .login will be read by the shell. If a command is specified, it is passed to the shell for execution via the shell's
-coption. If no command is specified, an interactive shell is executed.
sudoattempts to change to that user's home directory before running the shell. It also initializes the environment to a minimal set of variables, similar to what is present when a user logs in. The Command Environment section below documents in detail how the
-ioption affects the environment in which a command is run.
-K(sure kill) option is like
-kexcept that it removes the user's time stamp file entirely and may not be used in conjunction with a command or other option. This option does not require a password.
-k(kill) option to
sudoinvalidates the user's time stamp file. The next time
sudois run a password will be required. This option does not require a password and was added to allow a user to revoke
sudopermissions from a .logout file.
When used in conjunction with a command or an option that may
require a password, the
-k option will cause
sudo to ignore the user's time stamp file. As a
sudo will prompt for a password (if one
is required by sudoers) and will not update the user's
time stamp file.
-L(list defaults) option will list the parameters that may be set in a Defaults line along with a short description for each. This option will be removed from a future version of
-l(list) option will list the allowed (and forbidden) commands for the invoking user (or the user specified by the
-Uoption) on the current host. If a command is specified and is permitted by sudoers, the fully-qualified path to the command is displayed along with any command line arguments. If command is specified but not allowed,
sudowill exit with a status value of 1. If
-lis specified multiple times, a longer list format is used.
-n(non-interactive) option prevents
sudofrom prompting the user for a password. If a password is required for the command to run,
sudowill display an error message and exit.
-P(preserve group vector) option causes
sudoto preserve the invoking user's group vector unaltered. By default,
sudowill initialize the group vector to the list of groups the target user is in. The real and effective group IDs, however, are still set to match the target user.
-p(prompt) option allows you to override the default password prompt and use a custom one. The following percent (‘
%’) escapes are supported:
-uoption is also specified)
%’ characters are collapsed into a single ‘
The prompt specified by the
-p option will override the system password
prompt on systems that support PAM unless the
flag is disabled in sudoers.
-S(stdin) option causes
sudoto read the password from the standard input instead of the terminal device. The password must be followed by a newline character.
-s(shell) option runs the shell specified by the
SHELLenvironment variable if it is set or the shell as specified in the password database. If a command is specified, it is passed to the shell for execution via the shell's
-coption. If no command is specified, an interactive shell is executed.
-U(other user) option is used in conjunction with the
-loption to specify the user whose privileges should be listed. Only root or a user with the
ALLprivilege on the current host may use this option.
-u(user) option causes
sudoto run the specified command as a user other than root. To specify a uid instead of a user name, use #uid. When running commands as a uid, many shells require that the ‘
#’ be escaped with a backslash (‘
\’). Note that if the targetpw Defaults option is set (see sudoers(5)), it is not possible to run commands with a uid not listed in the password database.
-V(version) option causes
sudoto print its version string and exit. If the invoking user is already root the
-Voption will display the arguments passed to configure when
sudowas built as well a list of the defaults
sudowas compiled with as well as the machine's local network addresses.
sudowill update the user's time stamp file, authenticating the user's password if necessary. This extends the
sudotimeout for another
5minutes (or whatever the timeout is set to in sudoers) but does not run a command.
--option indicates that
sudoshould stop processing command line arguments.
Environment variables to be set for the command may also be passed
on the command line in the form of
Variables passed on the command line are subject to the same restrictions as
normal environment variables with one important exception. If the
setenv option is set in sudoers, the
command to be run has the
SETENV tag set or the
command matched is
ALL, the user may set variables
that would otherwise be forbidden. See
sudoers(5) for more
sudo requires that most users authenticate
themselves by default. A password is not required if the invoking user is
root, if the target user is the same as the invoking user, or if the
authentication has been disabled for the user or command in the
sudoers file. Unlike
sudo requires authentication, it validates the
invoking user's credentials, not the target user's (or root's) credentials.
This can be changed via the rootpw,
targetpw and runaspw Defaults entries in
If a user who is not listed in
sudoers tries to run a command via
sudo, mail is sent to the proper authorities. The
address used for such mail is configurable via the
sudoers Defaults entry and defaults to
Note that mail will not be sent if an unauthorized user tries to
sudo with the
-v option. This allows users to determine for
themselves whether or not they are allowed to use
sudo is run by root and the
SUDO_USER environment variable is set, its value
will be used to determine who the actual user is. This can be used by a user
to log commands through
sudo even when a root shell
has been invoked. It also allows the
-e option to
remain useful even when invoked via a sudo-run script or program. Note,
however, that the sudoers lookup is still done for root,
not the user specified by
sudo uses time stamp files
for credential caching. Once a user has been authenticated, the time stamp
is updated and the user may then use sudo without a password for a short
period of time (
5 minutes unless overridden by the
sudo uses a tty-based time stamp which
means that there is a separate time stamp for each of a user's login
sessions. The tty_tickets option can be disabled to force
the use of a single time stamp for all of a user's sessions.
sudo can log both successful
and unsuccessful attempts (as well as errors) to
syslog(3), a log file, or
both. By default,
sudo will log via
syslog(3) but this is
changeable via the
logfile Defaults settings.
sudo also supports logging a command's
input and output streams. I/O logging is not on by default but can be
enabled using the log_input and
log_output Defaults flags as well as the
Since environment variables can influence program behavior,
sudo provides a means to restrict which variables
from the user's environment are inherited by the command to be run. There
are two distinct ways sudoers can be configured to handle
with environment variables.
By default, the env_reset option
is enabled. This causes commands to be executed with a new, minimal
environment. On AIX (and Linux systems without PAM), the environment is
initialized with the contents of the
/etc/environment file. On BSD systems, if the
use_loginclass option is enabled, the environment is
initialized based on the path and setenv
settings in /etc/login.conf. The new environment
SUDO_* variables in addition to variables from the
invoking process permitted by the env_check and
options. This is effectively a whitelist for environment variables.
If, however, the env_reset option is disabled, any variables not explicitly denied by the env_check and env_delete options are inherited from the invoking process. In this case, env_check and env_delete behave like a blacklist. Since it is not possible to blacklist all potentially dangerous environment variables, use of the default env_reset behavior is encouraged.
In all cases, environment variables with a value
() are removed as they could be
interpreted as bash
functions. The list of environment variables that
sudo allows or denies is contained in the output of
sudo -V” when run as root.
Note that the dynamic linker on most operating systems will remove
variables that can control dynamic linking from the environment of setuid
sudo. Depending on the
operating system this may include
SHLIB_PATH, and others. These type of variables are
removed from the environment before
sudo even begins
execution and, as such, it is not possible for
to preserve them.
As a special case, if
-i option (initial login) is specified,
sudo will initialize the environment regardless of
the value of env_reset. The
TERM variables remain unchanged;
LOGNAME are set based on the target user. On AIX
(and Linux systems without PAM), the contents of
/etc/environment are also included. On BSD systems,
if the use_loginclass option is enabled, the
path and setenv variables in
/etc/login.conf are also applied. All other
environment variables are removed.
Finally, if the env_file option is defined, any variables present in that file will be set to their specified values as long as they would not conflict with an existing environment variable.
Upon successful execution of a program, the exit status from sudo will simply be the exit status of the program that was executed.
sudo exits with a value of 1 if
there is a configuration/permission problem or if
sudo cannot execute the given command. In the latter
case the error string is printed to the standard error. If
stat(2) one or more entries in
PATH, an error is printed on stderr. (If
the directory does not exist or if it is not really a directory, the entry
is ignored and no error is printed.) This should not happen under normal
circumstances. The most common reason for
stat(2) to return
“permission denied” is if you are running an automounter and
one of the directories in your
PATH is on a machine
that is currently unreachable.
sudo can log events using either
syslog(3) or a simple log
file. In each case the log format is almost identical.
Commands that sudo runs are logged using the following format (split into multiple lines for readability):
date hostname progname: username : TTY=ttyname ; PWD=cwd ; \ USER=runasuser ; GROUP=runasgroup ; TSID=logid ; \ ENV=env_vars COMMAND=command
Where the fields are as follows:
sudowas run on. This field is only present when logging via syslog(3).
sudowas run on, or “unknown” if there was no terminal present.
sudowas run in.
Messages are logged using the locale specified
which defaults to the “
If the user is not allowed to run the command, the reason for the denial will follow the user name. Possible reasons include:
-noption was specified but a password was required.
If an error occurs,
sudo will log a
message and, in most cases, send a message to the administrator via email.
Possible errors include:
sudoencountered an error when parsing the specified file. In some cases, the actual error may be one line above or below the line number listed, depending on the type of error.
sudofrom running, but the sudoers file should be checked using
sudotries to open sudoers using group permissions to avoid this problem.
On most systems,
syslog(3) has a relatively
small log buffer. To prevent the command line arguments from being
sudo will split up log messages that are
larger than 960 characters (not including the date, hostname, and the string
“sudo”). When a message is split, additional parts will
include the string “(command continued)” after the user name
and before the continued command line arguments.
If the logfile option is set, sudoers will log to a local file, such as /var/log/sudo. When logging to a file, sudoers uses a format similar to syslog(3), with a few important differences:
!’), word wrap will be disabled.
sudo tries to be safe when executing
To prevent command spoofing,
checks "." and "" (both denoting current directory) last
when searching for a command in the user's
one or both are in the
PATH). Note, however, that
PATH environment variable is
not modified and is
passed unchanged to the program that
sudo will check the ownership of its time
stamp directory (/var/run/sudo by default) and
ignore the directory's contents if it is not owned by root or if it is
writable by a user other than root. On systems that allow non-root users to
give away files via chown(2),
if the time stamp directory is located in a world-writable directory (e.g.,
/tmp), it is possible for a user to create the time
stamp directory before
sudo is run. However, because
sudo checks the ownership and mode of the directory
and its contents, the only damage that can be done is to
“hide” files by putting them in the time stamp dir. This is
unlikely to happen since once the time stamp dir is owned by root and
inaccessible by any other user, the user placing files there would be unable
to get them back out.
sudo will not honor time stamps set far in
the future. Time stamps with a date greater than current_time + 2 *
TIMEOUT will be ignored and sudo will log and
complain. This is done to keep a user from creating his/her own time stamp
with a bogus date on systems that allow users to give away files if the time
stamp directory is located in a world-writable directory.
Since time stamp files live in the file system, they can outlive a
user's login session. As a result, a user may be able to login, run a
sudo after authenticating, logout,
login again, and run
sudo without authenticating so
long as the time stamp file's modification time is within
5 minutes (or whatever the timeout is set to in
sudoers). When the tty_tickets
sudoers option is enabled, the time stamp has per-tty
granularity but still may outlive the user's session.
Please note that
normally only log the command it explicitly runs. If a user runs a command
sudo su or
subsequent commands run from that shell are not subject to
sudo's security policy. The same is true for
commands that offer shell escapes (including most editors). If I/O logging
is enabled, subsequent commands will have their input and/or output logged,
but there will not be traditional logs for those commands. Because of this,
care must be taken when giving users access to commands via
sudo to verify that the command does not
inadvertently give the user an effective root shell. For more information,
please see the
ESCAPES section in
To prevent the disclosure of potentially sensitive information,
sudo disables core dumps by default while it is
executing (they are re-enabled for the command that is run).
sudo utilizes the following environment
-e(sudoedit) mode if neither
-imode or when env_reset is enabled in sudoers, set to the mail spool of the target user.
-Hit specified, always_set_home is set in sudoers, or when the
-soption is specified and set_home is set in sudoers.
-Aoption is specified.
PS1will be set to its value for the program being run.
-uoption is specified).
-e(sudoedit) mode if
SUDO_EDITORis not set.
-imode on AIX and Linux systems
Note: the following examples assume suitable sudoers(5) entries.
To get a file listing of an unreadable directory:
$ sudo ls /usr/local/protected
To list the home directory of user yaz on a machine where the file system holding ~yaz is not exported as root:
$ sudo -u yaz ls ~yaz
To edit the index.html file as user www:
$ sudo -u www vi ~www/htdocs/index.html
To view system logs only accessible to root and users in the adm group:
$ sudo -g adm view /var/log/syslog
To run an editor as jim with a different primary group:
$ sudo -u jim -g audio vi ~jim/sound.txt
To shut down a machine:
$ sudo shutdown -r +15 "quick reboot"
To make a usage listing of the directories in the /home partition.
Note that this runs the commands in a sub-shell to make the
cd and file redirection work.
$ sudo sh -c "cd /home ; du -s * | sort -rn > USAGE"
See the HISTORY file in the
distribution (http://www.sudo.ws/sudo/history.html) for a brief history of
Many people have worked on
sudo over the
years; this version consists of code written primarily by:
See the CONTRIBUTORS file in the
distribution (http://www.sudo.ws/sudo/contributors.html) for an exhaustive
list of people who have contributed to
There is no easy way to prevent a user from gaining a root shell
if that user is allowed to run arbitrary commands via
sudo. Also, many programs (such as editors) allow
the user to run commands via shell escapes, thus avoiding
sudo's checks. However, on most systems it is
possible to prevent shell escapes with
functionality. See the
sudoers(5) manual for
It is not meaningful to run the
directly via sudo, e.g.,
$ sudo cd /usr/local/protected
since when the command exits the parent process (your shell) will still be the same. Please see the EXAMPLES section for more information.
Running shell scripts via
sudo can expose
the same kernel bugs that make setuid shell scripts unsafe on some operating
systems (if your OS has a /dev/fd/ directory, setuid shell scripts are
If you feel you have found a bug in
please submit a bug report at http://www.sudo.ws/sudo/bugs/
Limited free support is available via the sudo-users mailing list, see http://www.sudo.ws/mailman/listinfo/sudo-users to subscribe or search the archives.
sudo is provided “AS IS” and
any express or implied warranties, including, but not limited to, the
implied warranties of merchantability and fitness for a particular purpose
are disclaimed. See the LICENSE file distributed with
sudo or http://www.sudo.ws/sudo/license.html for
|January 16, 2015||OpenBSD-5.7|