|ISP(4)||Device Drivers Manual||ISP(4)|
isp — QLogic based
SCSI or Fibre Channel SCSI interface
isp* at pci? (PCI)
isp* at sbus? (SBus)
This driver provides access to a SCSI bus or a Fibre Channel connected to QLogic ISP1000 (SBus), ISP1020 (PCI), ISP1040 (PCI), ISP1080 (PCI), ISP12160 (PCI) SCSI host adapters or ISP2100 (PCI/SBus), ISP2200 (PCI/SBus) Fibre Channel or ISP2300 (PCI/SBus) 2-Gigabit Fibre Channel host adapters.
Features include support for UltraSCSI and wide mode transactions for SCSI, and Ultra2 LVD (for the ISP1080) and Ultra3 LVD (for the ISP12160) and the FCP SCSI (private loop, public loop or fabric) for Fibre Channel. Command tagging is supported for all (in fact, Fibre Channel requires tagging).
Unless the option ISP_NOFIRMWARE is added to the kernel configuration file, known good firmware will be downloaded to the driver at attach time.
isp driver was written by
Matthew Jacob for NASA/Ames Research Center.
|January 15, 2015||OpenBSD-5.7|